linux installation?
2018-01-17 18:45
Hello, i've a question:

i will run hamspere 4 with linux opensuse leap 42.3
openjdk-1.8, jre is installed.

Hamsphere is downloaded and unzipped.

asko@linux-ign7:~/hamsphere_4.010-native> ls
hamsphere_4.010 rt

asko@linux-ign7:~/hamsphere_4.010-native> ./hamsphere_4.010

Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /home/asko/hamsphere_4.010-native/rt/lib/i386/xawt/libmawt.so
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
Could not find the main class: com/hamsphere/core/HamSphere

What is it and why?

what do i wrong?

Installation and running with wine the win hamspere works, but i will use the linux version.

Can everybody help me?

Best regards. 73, 13hs921
Andreas
Re: linux installation?
2018-01-29 12:49
13HS921 Wrote:
-------------------------------------------------------
> Hello, i've a question:
>
> i will run hamspere 4 with linux opensuse leap
> 42.3


I'm having similar problems, It seemed to install easily a few years ago but now I'm trying to install it on later Ubuntu Linux Mint versions and it won't install anymore. I unzip to the hamsphere 4 native then open and get a folder named RT and an executable hamsphere_4.010 folder which used to run and the log in screen would open but now nothing happens. I can only assume it is being blocked by the increasing levels of java security.

Maybe somebody can explain what the problem is.

John G3VGU.
Re: linux installation?
2018-11-19 00:56
Any cure for this? Is it not compatable with a 64 bit system?
Re: linux installation?
2019-04-21 07:14
Attempting to run Hamsphere 4.0 on 64-bit linux...I get this:

[Amatuer@serveradministrator hamsphere_4.010-native]$ ./hamsphere_4.010


Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /home/Amatuer/Hamsphere/hamsphere_4.010-native/rt/lib/i386/xawt/libmawt.so
at Unknown.<unknown>(Unknown Source)
at Unknown.<unknown>(Unknown Source)
at Unknown.<unknown>(Unknown Source)
at Unknown.<unknown>(Unknown Source)
Could not find the main class: com/hamsphere/core/HamSphere



What is this?
Re: linux installation?
2019-05-04 07:51
Hi, I have written a manual for Hamsphere 4 in Feren OS

I will put this manual in this forum today..

Hans
Re: linux installation?
2019-09-17 06:12
The only way I have been able to get HS4 to run on 64 bit Linux is to run the Windows version under Wine. I believe the current version for Linux is for 32 bit only.
Re: linux installation?
2019-11-13 03:33
I am having the same issue. Sadly, the windows version isn't loading under the current wine. Any help is greatly appreciated.

Under Linux Native:

Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /home/kelly/Downloads/hamsphere_4.010-native/rt/lib/i386/xawt/libmawt.so
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
at Unknown.(Unknown Source)
Could not find the main class: com/hamsphere/core/HamSphere

System Ubuntu 10.10 X64


Under Wine 4.1.9

0009:fixme:dwmapi:DwmIsCompositionEnabled 0032F880
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 203
Current serial number in output stream: 204


Under Play on Linux with a 32 bit Wine 4.2 the same error occurs. Under an x64 install same error
Re: linux installation?
2019-11-23 21:02
Hi everyone,
Are there any Linux users who can advise me in the most basic manner, on how to install Hamsphere 4.0
on Linux Mint19.2 Cinnamon 64bit?
I am trying to get away from the problematic Windows 10 I have and know nothing about Linux.
I have downloaded it onto my laptop, found the download file but cannot find out how to finally run it to install fully.
Any help would be great. I am also trying to do the same using Ubuntu 19.10 in this months Linux Format magazine
but hitting the same brick wall.
Regards

Don
73 de G1EGI
Re: linux installation?
2019-12-24 22:51
Hi Don, I have HS4 working on Mint 19.2 and 19.3 64 bit. You have to install the 32 bit package ia32-libs it's in Synaptic and I think in the software package. It's a lot of files and as I don't know exactly what 32 bit files HS needs I installed the whole package. Copy the installation tar.gz Hamsphere installer to the home folder. Then in terminal type tar zxvf hamsphere_4.010-setup.tar.gz and then you get 3 folders and a sort of cog wheel in a square box. That is the executable file. Open it and you should get the log in screen. It sometimes takes a while before it appears at first once it opens then it should be instant next time.

HS 4 also works on Manjaro 64 bit without installing any 32 bit libraries , just do the same zxvf in terminal which unzips it into the same home folder. I find HS3 doesn't run on Mint comes up with a codec error but works in Manjaro but I find the received audio is crackly at times. To run HS3 in Manjaro in terminal it's Java -jar HS3 install file which is copied into the home folder.I have a removable hard drive bay so experiment with different linuxes.

Hope that may be of help.

John G3VGU
Re: linux installation?
2019-12-25 13:42
Hi and merry chrismas. :-)

Maybe ths thread can help as well: https://www.hamsphere.com/7_53194_read.html

73 and good DX from Jörg :-)
JO31ok
Bochum / Germany
Sorry, only registered users may post in this forum.

Click here to login